Forge Home

jitsimeet

Installs, configures and manages a Jitsi Meet instance

SMASH

smash

2,303 downloads

1,398 latest version

5.0 quality score

Version information

  • 1.0.0 (latest)
  • 0.2.0
  • 0.1.0
released May 7th 2020
This version is compatible with:
  • Puppet Enterprise 2021.3.x, 2021.2.x, 2021.1.x, 2021.0.x, 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x, 2019.0.x, 2018.1.x
  • Puppet >= 5.5.0
  • Debian

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'smash-jitsimeet', '1.0.0'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add smash-jitsimeet
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install smash-jitsimeet --version 1.0.0

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

smash/jitsimeet — version 1.0.0 May 7th 2020

jitsimeet

Table of Contents

  1. Description
  2. Setup
  3. Limitations
  4. Reference
  5. Development

Description

This module installs and manages a Jitsi Meet instance.

It currently only support Debian.

Setup

Setup Requirements

This module needs:

The following modules may also be required, depending on the options you use:

Explicit dependencies can be found in the project's metadata.json file.

Getting started

Here is an example of a working configuration:

  class { 'jitsimeet':
    jitsi_domain         => 'jitsi.example.com',
    manage_certs         => true,
    jitsi_vhost_ssl_key  => '/etc/letsencrypt/live/jitsi.example.com/privkey.pem'
    jitsi_vhost_ssl_cert => '/etc/letsencrypt/live/jitsi.example.com/cert.pem'
    auth_vhost_ssl_key   => '/etc/letsencrypt/live/auth.jitsi.example.com/privkey.pem'
    auth_vhost_ssl_cert  => '/etc/letsencrypt/live/auth.jitsi.example.com/cert.pem'
    jvb_secret           => 'mysupersecretstring',
    focus_secret         => 'anothersupersecretstring',
    focus_user_password  => 'yetanothersecret',
  }

Limitations

At the moment the only operating system supported is Debian 10 (Buster). The module might also work with compatible Ubuntu version, but this hasn't been widely tested.

For the other limitations, see the project's Issue Tracker.

Reference

The full reference documentation for this module may be found at on GitLab Pages.

Alternatively, you may build yourself the documentation using the puppet strings generate command. See the documentation for Puppet Strings for more information.

Development

This module's development is tracked on GitLab. Please submit issues and merge requests on the shared-puppet-modules-group/jitsimeet project page.