java8

Oracle Java8 Puppet Module

Spantree Technology Group, LLC

spantree

103,563 downloads

2,832 latest version

5.0 quality score

Version information

  • 0.7.0 (latest)
  • 0.6.1
  • 0.6.0
  • 0.5.2
  • 0.5.1
  • 0.5.0
  • 0.4.0
  • 0.3.0
  • 0.2.5
  • 0.2.4
  • 0.2.3
  • 0.2.2
released Jul 22nd 2019
This version is compatible with:
  • Puppet Enterprise 2019.1.x, 2019.0.x, 2018.1.x
  • Puppet >=5.5.0 <6.7.0
  • Debian
    ,
    Ubuntu

Start using this module

Documentation

spantree/java8 — version 0.7.0 Jul 22nd 2019

java8 Puppet Module

Build Status Puppet Forge Puppet Forge

Table of Contents

  1. Overview
  2. Module Description
  3. Setup - The basics of getting started with java8
  4. Usage - Configuration options and additional functionality
  5. Reference - An under-the-hood peek at what the module is doing and how
  6. Limitations - OS compatibility, etc.
  7. Development - Guide for contributing to the module

Overview

The module java8 installs the oracle java8 jdk on Ubuntu or Debian based system.

Module Description

This module adds a apt repository and then proceeds to install oracle jdk8

NOTE: This module may only be used if you agree to the Oracle license: http://www.oracle.com/technetwork/java/javase/terms/license/

Setup

What java8 affects

Setup Requirements

None at the moment.

Beginning with java8

include java8 is enough to get you up and running.

##Usage

All interaction with the java8 module can be done through the main java8 class.

###I just want Oracle java 8 jdk, what's the minimum I need?

include java8

##Reference

###Classes

####Public Classes

  • java8: Main class

###Parameters

###Facts

##Limitations

This module has been built on and tested against Puppet 3.2 and higher.

The module has been tested on:

  • Ubuntu 12.04
  • Ubuntu 14.04

Testing on other platforms has been light and cannot be guaranteed.

Development

Release Notes/Contributors/Etc

Thanks arpitaggarwal, PHDA and Conzar for their contributions.