Steven Merrill

Steven Merrill

stevenmerrill

8,995 downloads

8,793 latest version

1.1 quality score

Version information

  • 0.1.1 (latest)
  • 0.1.0
released Jul 3rd 2019
This version is compatible with:
  • Puppet Enterprise 3.x
  • Puppet 3.x
  • RedHat
    ,
    CentOS

Start using this module

Documentation

stevenmerrill/graphiteapi — version 0.1.1 Jul 3rd 2019

puppet-graphiteapi

(Also includes carbon.)

Starting with graphiteapi

Install the other modules that are needed.

include graphiteapi

This will set up:

  • Carbon using the packages
  • graphite-api running on localhost:8080.

Limitations

This module only runs on RHEL 6 to my knowledge.

This module does not provide for any configuration of Carbon yet.

Testing

There are no actual tests to speak of at this time.

I have personally tested this and gotten it to work with Grafana without issue.