Forge Home

pdagent

Puppet module for installing and managing the PagerDuty agent

8,866 downloads

8,753 latest version

5.0 quality score

Version information

  • 0.1.1 (latest)
  • 0.1.0
released May 14th 2015
This version is compatible with:
  • Puppet Enterprise 2021.6.x, 2021.5.x, 2021.4.x, 2021.3.x, 2021.2.x, 2021.1.x, 2021.0.x, 2019.8.x, 2019.7.x, 2019.5.x, 2019.4.x, 2019.3.x, 2019.2.x, 2019.1.x, 2019.0.x, 2018.1.x, 2017.3.x, 2017.2.x, 2017.1.x, 2016.5.x, 2016.4.x
  • Puppet >= 3.5.1
  • , ,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'walkamongus-pdagent', '0.1.1'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add walkamongus-pdagent
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install walkamongus-pdagent --version 0.1.1

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

walkamongus/pdagent — version 0.1.1 May 14th 2015

PagerDuty agent Puppet Module

Build Status

Table of Contents

  1. Overview
  2. Module Description - What the module does and why it is useful
  3. Setup - The basics of getting started with pdagent
  4. Usage - Configuration options and additional functionality
  5. Limitations - OS compatibility, etc.

Overview

This module installs and enables the PagerDuty agent.

Module Description

The PagerDuty agent is a daemon that enables PagerDuty integration with system and monitoring utilities. This module installs required repositories followed by the PagerDuty agent. It then enables the pdagent service and ensures the daemon is running.

Setup

What pdagent affects

  • Repositories
    • APT/YUM PagerDuty repositories
  • Packages
    • pdagent
    • pdagent-integrations
  • Services
    • pdagent daemon

Usage

Install the PagerDuty agent and ensure the pdagent service is running

class { '::pdagent': }

Limitations

Supports Puppet:

  • = 3.5.1

This module has been tested on:

  • RedHat 6,7
  • Debian 6,7
  • Ubuntu 14.04