nfsen

NfSen Orchestration

DataCentred

datacentred

8,337 downloads

5,344 latest version

4.3 quality score

Version information

  • 1.3.0 (latest)
  • 1.2.0
  • 1.1.4
  • 1.1.3
  • 1.1.2
  • 1.1.1
released Aug 10th 2016
This version is compatible with:
  • Puppet Enterprise 2017.2.x, 2017.1.x, 2016.5.x, 2016.4.x
  • Puppet >= 3.8.0 < 5.0.0
  • Ubuntu

Start using this module

Tags: nfsen

Documentation

datacentred/nfsen — version 1.3.0 Aug 10th 2016

NfSen

Build Status

Table Of Contents

  1. Overview
  2. Module Description
  3. Setup - The basics of getting started with nfsen
  4. Usage
  5. Limitations

Overview

Installs NfSen

Module Description

Installs nfdump and additional pre-requisite packages, clones the nfsen repository, configures and installs the application. Optionally installs an SSL secured web frontend with optional X.509 client verification. Note that this is based on puppet's PKI.

Setup

Setup Requirements

The following modules are required:

Usage

A basic stand alone nfsen with web gui is acheived via

include ::nfsen

However there are a few tweaks required to other modules to get a working setup via hiera

apache::default_vhost: false
apache::mpm_module: 'prefork'

Limitations

  • Only tested on Ubuntu Trusty 14.04