neovim

Neovim management

Kevin James

thekevjames

7,701 downloads

5,944 latest version

4.3 quality score

Version information

  • 1.5.0 (latest)
  • 1.4.1
  • 1.4.0
  • 1.3.1
  • 1.3.0
  • 1.2.1
  • 1.2.0
  • 1.1.0
  • 1.0.0
released Apr 18th 2016
This version is compatible with:
  • Puppet Enterprise 2017.2.x, 2017.1.x, 2016.5.x, 2016.4.x
  • Puppet >= 4.3.0 < 5.0.0
  • CentOS, Darwin, Debian, Fedora, Ubuntu

Start using this module

Documentation

thekevjames/neovim — version 1.5.0 Apr 18th 2016

puppet-neovim

An opinionated Puppet Module to install and manage Neovim.

puppet-neovim is available on the Puppet Forge.

Usage

Simply

class { '::neovim':
  home => '/home/kevin',
}

to make sure neovim is installed.

Configuration

In addition to the above value set for neovim, you can also use hiera to override the following defaults:

neovim::dependencies: nil
neovim::packages: neovim