Forge Home

mariadbrepo

A puppet module that configure the MariaDB repository on an Enterprise Linux (and relatives) system

20,106 downloads

17,784 latest version

3.1 quality score

We run a couple of automated
scans to help you access a
module's quality. Each module is
given a score based on how well
the author has formatted their
code and documentation and
modules are also checked for
malware using VirusTotal.

Please note, the information below
is for guidance only and neither of
these methods should be considered
an endorsement by Puppet.

Version information

  • 0.2.1 (latest)
  • 0.2.0
  • 0.1.2
  • 0.1.1
  • 0.1.0
released Mar 26th 2015
This version is compatible with:
  • Puppet 3.x
  • , , , Debian,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'yguenane-mariadbrepo', '0.2.1'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add yguenane-mariadbrepo
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install yguenane-mariadbrepo --version 0.2.1

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

yguenane/mariadbrepo — version 0.2.1 Mar 26th 2015

#puppet-mariadbrepo

Build Status

##Overview

A puppet module that configure the MariaDB repository on a Linux system.

##Module Description

Based on your system specifications, this module will install a the repository to install MariaDB.

##Usage

As it simplest, simply include the mariadbrepo class

include mariadbrepo

If one wants a specific version of MariaDB simply specify it (default is 10.0)

class {'mariadbrepo' :
  version => '5.5',
}

##Parameters

####mirror

Specify the mirror to pull the packages from (ie. Debian based OS only)

####version

Version of MariaDB repo to install. Current Possible values are '5.5' or '10.0' (default)

##Limitations

This module works for :

  • EL5/6/7
  • Fedora 19/20/21
  • Debian 6/7
  • Ubuntu 10.04/12.04/14.04/14.10