Forge Home

postgresqlrepo

A puppet module that configure the PostgreSQL repository on an Enterprise Linux (and relatives) system

8,731 downloads

8,731 latest version

3.0 quality score

Version information

  • 0.1.0 (latest)
released Jun 28th 2014
This version is compatible with:
  • Puppet 3.x
  • , ,

Start using this module

  • r10k or Code Manager
  • Bolt
  • Manual installation
  • Direct download

Add this module to your Puppetfile:

mod 'yguenane-postgresqlrepo', '0.1.0'
Learn more about managing modules with a Puppetfile

Add this module to your Bolt project:

bolt module add yguenane-postgresqlrepo
Learn more about using this module with an existing project

Manually install this module globally with Puppet module tool:

puppet module install yguenane-postgresqlrepo --version 0.1.0

Direct download is not typically how you would use a Puppet module to manage your infrastructure, but you may want to download the module in order to inspect the code.

Download

Documentation

yguenane/postgresqlrepo — version 0.1.0 Jun 28th 2014

#puppet-postgresqlrepo

Build Status

##Overview A puppet module that configure the PostgreSQL repository on an Enterprise Linux (and relatives) system

##Module Description Based on your system specifications, this module will install a the repository to install PostgreSQL packages.

Note: As specified in the description, it works only for Enterprise Linux and its relatives.

##Usage

As it simplest, simply include the postgresqlrepo class

include postgresqlrepo

If one wants a specific version of PostgreSQL simply specify it (default is 9.3)

class {'postgresqlrepo' :
  version            => '9.1',
  repo_source_enable => true,
}

##Parameters

####version

Version of the PostgreSQL repo to install. Current Possible values are '8.4', '9.0', '9.1', 9.2' or '9.3' (default)

####repo_enable

Whether or not to enable the main PostgreSQL repository (boolean)

####repo_source_enable

Whether or not to enable the source PostgreSQL repository (boolean)

##Limitations

This module works for :

  • EL5
  • EL6
  • Fedora 19/20